$re = '/(?<!\d)(\d{1,2}|100)(?!\d)/m';
$str = '6 4 88 100 345 34534 2334 100 435 45 33 345345 100 4334 100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);