$re = '/\n^\s{16,}/m';
$str = '{
"bulbasaur": {
"num": 1,
"name": "Bulbasaur",
"slug": "bulbasaur",
"generation": 1,
"forms": {
"bulbasaur": {
"name": "Bulbasaur",
"slug": "bulbasaur",
"formName": null,
"formSlug": null,
"showdownName": "Bulbasaur",
"generation": 1,
"sprite": "0001-0100/0001",
"menuSprite": "bulbasaur",
"isDefault": true,
"isFemale": false,
"isCosmetic": false,
"isBattleOnly": false,
"isCloudStorable": true,
"isFusion": false,
"isMega": false,
"isPrimal": false,
"isGigantamax": false,
"isTotem": false,
"isRegional": false,
"hasGenderDifferences": false,
"hasGmax": false,
"hasMega": false,
"data": {
"gen8": {
"generation": 8,
"type1": "grass",
"type2": "poison",
"eggGroup1": "monster",
"eggGroup2": "grass",
"ability1": "overgrow",
"ability2": null,
"abilityHidden": "chlorophyll",
"height": 0.7,
"weight": 6.9,
"color": "green",
"shape": "?",
"maleRatio": 0.875,
"femaleRatio": 0.125,
"baseHp": 45,
"baseAttack": 49,
"baseDefense": 49,
"baseSpAttack": 65,
"baseSpDefense": 65,
"baseSpeed": 45,
"baseStatsTotal": 318,
"weightPercentile": 26.85337726523888,
"heightPercentile": 37.191103789126856,
"baseHpPercentile": 14.209225700164746,
"baseAttackPercentile": 13.797364085667216,
"baseDefensePercentile": 17.751235584843492,
"baseSpAttackPercentile": 44.275123558484346,
"baseSpDefensePercentile": 40.362438220757824,
"baseSpeedPercentile": 22.03459637561779,
"baseStatsTotalPercentile": 18.57495881383855
}
}
}
},
"formsOrder": [
"bulbasaur"
]
}
}';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;