const regex = /\b[Tt]he\b|\b[Tt]hen*\b|\bextratheaterly\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[Tt]he\\b|\\b[Tt]hen*\\b|\\bextratheaterly\\b', 'gm')
const str = `If the world says that theo is not oreo cookies then thetatheoder is extratheaterly good.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}