#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)\b([Vv][ao]n\s\w+|(?:[Dd][eu]\s\p{L}+|La\s\p{L}+|St\.\s\w+|Auf\sder\s\w+))(.*)"
Local $sString = "Emile La Sére" & @CRLF & _
"George A. La Dow" & @CRLF & _
"Gilbert De La Matyr" & @CRLF & _
"Robert M. La Follette" & @CRLF & _
"William Leroy La Follette" & @CRLF & _
"Robert M. La Follette Sr." & @CRLF & _
"Robert M. La Follette Jr." & @CRLF & _
"Charles M. La Follette" & @CRLF & _
"Monica De La Cruz" & @CRLF & _
"David A. De Armond" & @CRLF & _
"Justin De Witt Bowersock" & @CRLF & _
"De Witt C. Giddings" & @CRLF & _
"Julien de Lallande Poydras" & @CRLF & _
"Henry St. John" & @CRLF & _
"Edward St. Loe Livermore" & @CRLF & _
"Oscar L. Auf der Heide" & @CRLF & _
"Kika de la Garza"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")