import re
regex = re.compile(r"^(|[0-9A-Z]{4}| {1}[0-9A-Z]{3}| {2}[0-9A-Z]{2}| {3}[0-9A-Z])$", flags=re.MULTILINE)
test_str = ("1 A3\n"
"1 \n"
" \n"
"A 1 \n\n"
" X\n"
" 43\n"
" D42\n"
"AB23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")