// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?im)(http:\/\/dx.doi.org\/10|10| DOI: 10|DOI:10).\d{4,9}\/[-._;()\/:0-9]+").unwrap();
  let string = "Small Group Research2014, Vol. 45(6) 671 Œ703© The Author(s) 2014Reprints and permissions:sagepub.com/journalsPermissions.nav DOI: 10.1177/1046496414552285sgr.sagepub.comArticleA Conceptual Review of Emergent State 
Measurement: Current 
Problems, Future 
SolutionsChris W. Coultas1, Tripp Driskell2,  C. Shawn Burke1, and Eduardo Salas1AbstractTeam research increasingly incorporates emergent states as an integral 
mediator between team inputs and outcomes. In conjunction with this, we 
have witnessed a proliferation and fragmentation of measurement techniques 
associated with emergent states. This inconsistency in measurement presents 
a problem for scientists and practitioners alike. For the scientist, it becomes 
difficult to better understand the nature and effects of various emergent 
states on team processes and outcomes. For the practitioner, it complicates 
the process of measurement development, selection, and implementation. 
To address these issues, we review the literature on emergent states focusing 
on various measurement strategies, to better unpack best practices. In so 
doing, we highlight existing research that suggests innovative solutions to the 
conceptual, methodological, and logistical problems that consistently plague 
emergent state research. Our aim is to enhance emergent state theory by 
applying psychometric principles to the measurement techniques associated 
with them.1University of Central Florida, Orlando, USA2The Florida Maxima Corporation, Orlando, USACorresponding Author:Chris W. Coultas, University of Central Florida, 4000 Central Florida Blvd., Psychology Bldg. 
99, Ste. 320, Orlando, FL 32816, USA. 
Email: ccoultas@ist.ucf.eduThis article is part of the special issue: 2014 Annual Review Issue, Small Group Research, Volume 45(6).552285SGRXXX10.1177/1046496414552285
Small Group ResearchCoultas et al.research-article
2014
";
  
  // result will be a tuple containing the start and end indices for the first match in the string
  let result = regex.captures(string);
  
  let (start, end) = match result {
    Some((s, e)) => (s, e),
    None => {
        // ...
    }
  };
  
  
  println!("{}", &string[start, end]);
}