$re = '/"[^"]+":[0-9]+/';
$str = '{"bla":29, "foo":30}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);