$re = '/((?:(?:\d+) (?:years?|months?|weeks?|days?|hours?|minutes?|seconds?)(?: ago)?[ ,]+)+)/';
$str = '3 weeks ago 5 minutes, 49 seconds
5 months ago 42 minutes
6 months ago 40 minutes
7 months ago 9 minutes, 39 seconds
7 months ago 31 minutes
7 months ago 1 hour
8 months ago 1 hour, 3 minutes ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);