re = /^\s*((?:[—‘’ \-\w?°]|(?<=\w)[.,:])+?[^ .])[., ]*([-\d]+)$/m
str = 'Preface page -1
Preface 2: The Unconscious Juggling of Mental Objects . . . . . ... ... .87
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end