import re
regex = re.compile(r"\"Status\":(\"?)(?<cstatus>.*?)(\"?),.*?\"ProblemFlag\":(\"?)(?<probflag>.*?)(\"?),.*?\"IncreasePending\":(\"?)(?<increasePend>.*?)(\"?),.*?\"SafePay\":(\"?)(?<safepay>.*?)(\"?),.*?\"PastDue\":(\"?)(?<pastdue>.*?)(\"?),.*?\"LastPmtAmt\":(\"?)(?<lastpayamt>.*?)(\"?),.*?\"NextPmtAmt\":(\"?)(?<nextpayamt>.*?)(\"?),.*?\"LastPayDate\":(\"?)(?<lastpaydate>.*?)(\"?),.*?\"NextDebitDate\":(\"?)(?<nextdbtdate>.*?)(\"?),.*?\"AddendumDate\":(\"?)(?<addendmdate>.*?)(\"?)(,?)}", flags=re.MULTILINE)
test_str = "{\"Status\":\"AP\",\"ProblemFlag\":\"0\",\"IncreasePending\":\"1\",\"SafePay\":\"1\",\"PastDue\":\"0\",\"LastPmtAmt\":\"0.00\",\"NextPmtAmt\":\"453.00\",\"LastPayDate\":\"\",\"NextDebitDate\":\"2021-02-28 00:00:00\",\"AddendumDate\":\"2021-02-15 00:00:00\"}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")