$re = '~\b\p{N}+\s+(?:an|year)s?~m';
$str = '"I\'m 24 years old" "J\'ai 25 ans"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);