$re = '/^(?!$)(\d+gal($|-(?!$)))?(\d+qt($|-(?!$)))?(\d+pt($|-(?!$)))?(\d+cup($|-(?!$)))?(\d+oz($|-(?!$)))?$/m';
$str = '
1gal
1gal-1qt-2pt-2cup-5oz
1gal-1qt-2pt-2cup-5o
1gal-1qt-2oz-2cup
1gal-1qt-2oz-2cup
1gal-1qt-2oz
-1gal-1qt-2oz
1gal-1qt-2oz-
%0 = ^(?!$)(%ngal%d)?(%nqt%d)?(%npt%d)?(%ncup%d)?(%noz%d)?$
%d = ($|-(?!$))
%n = \\d+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);