package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^([A-Za-z]+-?[A-Za-z0-9]{4,14}[A-Za-z0-9])$`)
var str = `PeterPorkerdsdsds
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}