use strict;
my $str = '
* asterisk 1
* asterisk 2
* asterisk 3
* * *
';
my $regex = qr/(?:(?<=^\n)|(?<=\A))
(?<list_all>
(?<list_prefix>
[\s]{0,3}
(?<list_type_any>
(?:
(?<list_type_unordered_star>(?&list_unordered_star))
|
(?<list_type_unordered_minus>(?&list_unordered_minus))
|
(?<list_type_unordered_plus>(?&list_unordered_plus))
|
(?<list_type_ordered>(?&list_ordered))
)
)
[ \t]+
)
(?<list_content>(?s:.+?))
(?<list_after>
\z
|
\n{2,}
(?=\S)
(?!
[ \t]*
(?<list_type_any2>
(?:
(?<list_type_unordered_star2>(?&list_unordered_star))
|
(?<list_type_unordered_minus2>(?&list_unordered_minus))
|
(?<list_type_unordered_plus2>(?&list_unordered_plus))
|
(?<list_type_ordered2>(?&list_ordered))
)
)
[ \t]+
)
)
)
(?(DEFINE)
(?<list_unordered_star>
[\*]
(?!
(?:
[ ]?[\*][ ]?
){2,}
)
)
(?<list_unordered_minus>
[\-]
(?!
(?:
[ ]?[\-][ ]?
){2,}
)
)
(?<list_unordered_plus>[\+])
(?<list_ordered>\d+[\.])
)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}