$re = '/(?:\G(?!^)\s*,\s*|(?=\w+(?:,\s*\w+)+))(\w+)/m';
$str = 'fruits: apple, orange, banana';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);