#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}Z)\s+(?<level>\w+)\s+(?<module>\w+)\]\s+(?<body>.*)$"
Local $sString = "[2017-11-09T02:12:24Z DEBUG my_app] this is a debug message" & @CRLF & _
"[2017-11-09T02:12:24Z ERROR my_app] this is printed by default" & @CRLF & _
"[2017-11-09T02:12:24Z INFO my_app] the answer was: 12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")