$re = '/<li[^>]*>(?:(?!<li>).*?)<\/li>/m';
$str = '<li><li>Что угодно</li></li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);