package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bthe[mn]\b`)
var str = `them then there theme
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}