$re = '/(?i)a[bd]a/m';
$str = 'abc ABA Ada';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);