$re = '/^3(?:[0-25-9][0-9]|[34][1-9])\.[0-9]{3}$/m';
$str = '345.678
340.889
330.750
356.111
123.456
1324.45764576
341.678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);