package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"]+"|[^"\s]+`)
var str = ` "path/to/program.exe" -a -b -c`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}