package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((?:\([^()]*?\)|([^()]*\bgreen\b[^()]*)?|[^()])*?\)`)
var str = `OSDfhosjdjakjdnvkjndkfvjelkrjejrijrvrvrjvnkrjvnkn(mint (light) green pants)shdbfhsbdhfbsjd(couch)hvbjshdbvjhsbdfbjs(forest (dark) (stained) green shirt) sjdfjsdhfjshkd(fjskdjfksjdfhfskdjf(green table) (green)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}