$re = '/^.*\._namefile\.java$/m';
$str = 'anything_here/anything_there._namefile.java
anything_here/anything_there/anything_everywhere._namefile.java
anything_here/anything_there_namefile.java';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);