$re = '/.*min:(?<MIN>(\d*))/m';
$str = 'min:5|max:50000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);