package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*min:(?<MIN>\d*))(.*max:(?<MAX>\d*))`)
var str = `required|min:5|max:50000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}