$re = '/(?:\{|(?<!^)\G)[^#\r\n]*\K#+(?=[^}]*\})/m';
$str = '(C##nH##{##2##n}O##2)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;