re = /[^\\\/]*(?:\\.[^\\\/]*)*(?=\/|$)/m
str = '\\\\\\\\\\\\/a b/c\\/d\\\\/e\\\\\\/f1/2\\\\\\\\\\\\\\/23/99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end