package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(.*?)(?:<!-- MAIN CONTENT -->)`)
var str = `Все что до
<!-- MAIN CONTENT -->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}