re = /My name is '([^']+?)' and I live in ([^']+?)(?: capital|)(?: and I like ([^']+?)|)(?: programming| reading|)/m
str = 'My name is \'Mark\' and I live in Spain capital and I like computers programming'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end