$re = '/^(?P<name>[^\d]+)(?P<id>(?<= )\d+)?$/';
$str = 'Mr. John Smith 1111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);