#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[ ])CO(?!MPANY)(?:[MPANY]+(?:(?:[ ])|$)|(?:[ ])|(?=\#)|$)"
Local $sString = " COMPANY" & @CRLF & _
" COPMANY" & @CRLF & _
" CO" & @CRLF & _
" COMP" & @CRLF & _
" CO " & @CRLF & _
" COMP " & @CRLF & _
" COMPNY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")