package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^ろ]+ろ`)
var str = `いろはにほへとちりぬるをわかよたれそつねならむういのおくやまけふこえてあさきゆめみしゑひもせ すん`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}