re = /\S+ (?:IN|[<=>]+) (?:\([^)]+?\)|\S+)/i
str = 'where c.value IN (3,4,5,6)
Where c.value = 32
SELECT C.NAME, C.FIRSTNAME FROM CUSTOMER C, PROSPECT P WHERE C.ID = 32 AND C.TRUC = 28 AND P.ID < 12 AND P.A IN (2, 3, 4)
WHERE C.ID <= 32 AND C.TRUC >= 28 AND P.ID < 12 AND P.ID > 12 AND P.ID = 12 AND P.A IN (2, 3, 4)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end