$re = '/(\d+)(?=.*\.)/m';
$str = 'file 1 with 12 many 100 numbers 3.mp4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);