$re = '/(\d+)/';
$str = 'https://vk.com/album2321909_116026875';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);