$re = '/(<blockquote.*?class=\'instagram-media\'[^>]*>)(.*?)(<\/blockquote>)/im';
$str = '<blockquote class=\'instagram-media\' data-instgrm-captioned data-instgrm-permalink=\'https://www.instagram.com/p/BjaT3cgBHp4/\' data-instgrm-version=\'8\' style=\' background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);\'><div style=\'padding:8px;\'> <div style=\' background:#F8F8F8; line-height:0; margin-top:40px; padding:50.0% 0; text-align:center; width:100%;\'> <div style=\' background:url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACwAAAAsCAMAAAApWqozAAAABGdBTUEAALGPC/xhBQAAAAFzUkdCAK7OHOkAAAAMUExURczMzPf399fX1+bm5mzY9AMAAADiSURBVDjLvZXbEsMgCES5/P8/t9FuRVCRmU73JWlzosgSIIZURCjo/ad+EQJJB4Hv8BFt+IDpQoCx1wjOSBFhh2XssxEIYn3ulI/6MNReE07UIWJEv8UEOWDS88LY97kqyTliJKKtuYBbruAyVh5wOHiXmpi5we58Ek028czwyuQdLKPG1Bkb4NnM+VeAnfHqn1k4+GPT6uGQcvu2h2OVuIf/gWUFyy8OWEpdyZSa3aVCqpVoVvzZZ2VTnn2wU8qzVjDDetO90GSy9mVLqtgYSy231MxrY6I2gGqjrTY0L8fxCxfCBbhWrsYYAAAAAElFTkSuQmCC); display:block; height:44px; margin:0 auto -44px; position:relative; top:-22px; width:44px;\'></div></div> <p style=\' margin:8px 0 0 0; padding:0 4px;\'> <a href=\'https://www.instagram.com/p/BjaT3cgBHp4/\' style=\' color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;\' target=\'_blank\'>11 days after the #RoyalWedding & Iām still tryna find someone to hold my hand and do the thumb thing like this š©š©</a></p> <p style=\' color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;\'>A post shared by <a href=\'https://www.instagram.com/accessonline/\' style=\' color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;\' target=\'_blank\'> Access</a> (@accessonline) on <time style=\' font-family:Arial,sans-serif; font-size:14px; line-height:17px;\' datetime=\'2018-05-30T18:09:36+00:00\'>May 30, 2018 at 11:09am PDT</time></p></div></blockquote>';
$subst = "\1</blockquote>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;