#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mX)^(?P<deutsch>(?:(?P<subjekt>(?:in\s)?(?:(?P<sich>sich)|etw\.|jd[mn]\.))\s)*(?P<wort>[\wäÄéöÖüÜß]+)(?:\s(?:(?P<rektion>(?:von|für|an)\s\((?:Dat|Akk)\))|\((?P<extra>[^\)]+)\)))*)\s(?P<definition>(?:[\wáéíóöőúüűÁÉÍÓÖŐÚÜŰ]|[ :,\/\(\);]|\-\n)+)$"
Local $sString = "abnehmen (nahm ab, abge-" & @CRLF & _
"nom men) itt: csökken, fogy" & @CRLF & _
"sich abwenden von (Dat)" & @CRLF & _
"elfordul vkitől/vmitől" & @CRLF & _
"sich etw. anhören meghallgat vmit" & @CRLF & _
"anregen (fel)élénkít, felpezs-" & @CRLF & _
"dít, ösztönöz" & @CRLF & _
"jdm. auffallen (fiel auf, ist auf-" & @CRLF & _
"gefallen) feltűnik vkinek vmi" & @CRLF & _
"sich etw. ausleihen (lieh aus," & @CRLF & _
"ausgeliehen) kikölcsönöz magának vmit" & @CRLF & _
"aussterben (starb aus, ist aus-" & @CRLF & _
"gestorben) kihal" & @CRLF & _
"auszeichnen itt: jellemez vkit/vmit, jellemző vkire/vmire" & @CRLF & _
"behandeln kezel vkit/vmit; tárgyal/kifejt vmit" & @CRLF & _
"benachrichtigen értesít" & @CRLF & _
"jdn. bilden képez, művel vkit" & @CRLF & _
"davonlaufen (lief davon, ist" & @CRLF & _
"davongelaufen) elfut" & @CRLF & _
"jdm. drohen (meg)fenyeget vkit" & @CRLF & _
"durchlesen (las durch, durch-" & @CRLF & _
"gelesen) átolvas" & @CRLF & _
"in etw. eintauchen (tauchte" & @CRLF & _
"ein, ist eingetaucht) bele-" & @CRLF & _
"merül vmibe" & @CRLF & _
"sich entscheiden für (Akk)" & @CRLF & _
"(entschied, entschieden)" & @CRLF & _
"dönt vmi/vki mellett" & @CRLF & _
"jdn. erwischen bei (Dat) vkit" & @CRLF & _
"rajtakap vmin" & @CRLF & _
"fesseln lebilincsel, leköt" & @CRLF & _
"fördern erősít, (elő)segít, támogat" & @CRLF & _
"jdm. gelingen (gelang, ist ge-" & @CRLF & _
"lungen) sikerül vkinek vmi" & @CRLF & _
"jdm. etw. gestehen (gestand," & @CRLF & _
"gestanden) bevall vkinek vmit" & @CRLF & _
"graben (grub, gegraben) itt: (bele)vés, (bele)metsz" & @CRLF & _
"sich kümmern um (Akk) törő-" & @CRLF & _
"dik vkivel/vmivel" & @CRLF & _
"liegen an (Dat) (lag, gelegen)" & @CRLF & _
"múlik vkin/vmin, függ vkitől/vmitőlloben dicsér" & @CRLF & _
"senken csökkent" & @CRLF & _
"schulen fejleszt, képez" & @CRLF & _
"schwanken (zwischen) inga-" & @CRLF & _
"dozik, nem tud dönteni (dolgok között)" & @CRLF & _
"jdm. etw. stehlen (stahl, ge-" & @CRLF & _
"stoh len) ellop vkitől vmit" & @CRLF & _
"steigern növel, fokoz" & @CRLF & _
"übernehmen (übernahm, über-" & @CRLF & _
"nommen) átvesz, (át)vállal" & @CRLF & _
"überraschen meglep" & @CRLF & _
"überreden zu (Dat) rábeszél vmire" & @CRLF & _
"übersehen (übersah, überse-" & @CRLF & _
"hen) nem vesz észre, elnéz" & @CRLF & _
"etw. übersetzen lefordít" & @CRLF & _
"vergleichen (verglich, vergli-" & @CRLF & _
"chen) összehasonlít" & @CRLF & _
"verlernen elfelejt" & @CRLF & _
"vermitteln közvetít" & @CRLF & _
"vertonen megzenésít" & @CRLF & _
"vervielfältigen sokszorosít" & @CRLF & _
"verwenden használ" & @CRLF & _
"jdm. etw. vorlesen (las vor," & @CRLF & _
"vor gelesen) felolvas vkinek vmit" & @CRLF & _
"etw. vorstellen bemutat vmit" & @CRLF & _
"zusammenstellen összeállít"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")