$re = '/^(?:(\d{4}\-\d\d\-\d\d)|(\d{4}\-\d\d\-\d\d([tT][\d:\.]*))([zZ]|([+\-])(\d\d):?(\d\d))?)$/mi';
$str = '2014-12-23
2014-12-23t
2014-12-23T
2014-12-23Tz
2014-12-23T12:22.222Z
2014-12-23T12:22.222-22:22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);