package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d|\d\d|[01]\d\d|2[0-4]\d|25[0-5])\.(\d|\d\d|[01]\d\d|2[0-4]\d|25[0-5])\.(\d|\d\d|[01]\d\d|2[0-4]\d|25[0-5])\.(\d|\d\d|[01]\d\d|2[0-4]\d|25[0-5])`)
var str = `111.111.111.111`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}