$re = '/v\d(?!\d)/m';
$str = '123v1
123v01
123v001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);