re = /(?<=(?<!\\)(['"])).+?(?=(?<!\\)\1)|(?<=^|['"]).+?(?=(?<!\\)['"]|$)/m
str = 'Telling myself \'you are \\\'great\\\' \' and then saying "thank you" feels "a \\"little\\" nice"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end