re = /(\d+.F\))/
str = 'Friday: Thundery Shower, Maximum Temperature: 27°C (81°F) Minimum Temperature: 17°C (63°F)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end