$re = '/(\w+)\(/m';
$str = 'int main(int argc, char** argv) {
std::puts(\'Hello World\');
return 0;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);