re = /^(?:(?:\/.+)+\/contactos\/?)$|^(?:(?:\/.*)+\/gestao(?:\/.+))$/
str = '/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao/stao'
# Print the match result
str.match(re) do |match|
puts match.to_s
end