$re = '/(?<!precedido)Regex2017/';
$str = 'sucedidoRegex2017
precedidoRegex2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);