re = /^[\s]*(.*?)[\s]*$/m
str = 'test
avoid starting spaces
avoid ending spaces
avoid starting and ending spaces '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end