import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\*]*Highlight \\[page [^\\]]*\\]: ?[\\*]* ?)";
final String string = "**Highlight [page 1]:** Effectiveness of Measures to Eradicate Staphylococcus aureus Carriage in Patients with Community-Associated Skin and Soft Tissue Infections:\n\n"
+ "**Highlight [page 1]:** Background—Despite a paucity of evidence, decolonization measures are prescribed for outpatients with recurrent Staphylococcus aureus skin and soft tissue infections (SSTI).\n\n"
+ "**Highlight [page 1]:** Participants were randomized to receive no therapeutic intervention (controls) or perform one of three 5-day regimens: 2% mupirocin ointment applied to the nares twice daily, intranasal mupirocin plus daily 4% chlorhexidine body washes, or intranasal mupirocin plus daily dilute bleach water baths.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}