$re = '/^(?:[^_]+_){2}\K[^_]+/m';
$str = 'AAA_BBB_CCC_DDD:1111111_1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);