package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^href="]*"index\.php\?option=com_k2&view=item&id=\d{2,4}:[A-Za-z0-9]+(?:-[A-Za-z0-9]+)*[\w\-]*)\.html`)
var str = `<p><a href="index.php?option=com_k2&view=item&id=6238:alias-title-of-an-article" target="_blank">Lorem ipsum dolor sit amet</a>, consectetur adipiscing elit. Donec sed consequat erat, eu interdum est. <a href="index.php?option=com_k2&view=item&id=6238:alias-title-of-an-article.html" target="_blank">Integer auctor</a>Nam sagittis vestibulum tortor non convallis. . Nulla pellentesque urna et urna accumsan, a accumsan nibh iaculis. Quisque faucibus sed arcu ac imperdiet. Duis pulvinar interdum libero, vel sodales lorem elementum sit amet. Sed ullamcorper vulputate metus, non pretium enim lacinia vel. Pellentesque gravida euismod lorem at scelerisque. Ut ultricies dolor dolor, quis luctus est cursus a.<a href="index.php?option=com_k2&view=item&id=1163:10-iphone-photo-tips-and-tricks.html" target="_blank">10 κόλπα για σαφώς καλύτερες λήψεις φωτογραφιών</a> In vulputate, tortor vel ornare semper, sapien dolor rutrum augue, ut condimentum eros quam eget sapien. In sagittis ut mauris ut rutrum. Nulla sodales gravida nunc, et sollicitudin nisl viverra ut. Curabitur nec malesuada mauris. Mauris tempus mollis erat, vel euismod magna. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas.</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}