// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<before>.*?)(?P<code>CR\d+)(?P<after>.*)").unwrap();
let string = "antes before CR1234 after siguiente
antes before CR12345 after siguiente
antes before CR123456 after siguiente";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}